List of Applications Not Compatible with Snow Leopard

From Mac Guides

Jump to: navigation, search

Below is a list of applications not performing well under Snow Leopard. This article is split into three sections; Applications with major problems, applications with minor issues, and applications now fully Snow Leopard compatible.

Older software which has not been updated to the latest version may also experience issues. Make sure you've downloaded all the available software updates for your applications before testing them under Snow Leopard.

Contents

Applications with unknown status

  • Americas Army 2.5 (PPC App -- Install Rosetta from CD and find out.)
  • CS1 (PPC App -- Install Rosetta from CD and find out.)
  • CS2 (PPC App -- Install Rosetta from CD and find out.)

Applications with Major Issues

  • All WireTap Versions (FIX SOON!)
  • ArchiveMac (getting fixed)
  • calibre (Random Crashes)
  • Citrix Online Plug-in for Mac
  • DataBackup 3.05
  • FLIQLO 1.1 screensaver
  • iWork '05 (Pages & Keynote)
  • Limechat
  • Line 6 Monkey
  • Linkinus
  • LiveScribe Pulse Smartpen Software
  • MacSpeech Dictate
  • magnifique
  • MailTags
  • Max
  • Menumeters (pref pane doesn't load)
  • Multi-clutch
  • Nambu
  • NodeToad
  • NX Client for OSX
  • OneSwarm
  • OnyX (Upcoming version 2.1 will be compatible)
  • PlayBack 1.0.4
  • PleaseSleep
  • Reader Notifier
  • RealVNC
  • Reunion 9 (The makers are advising people to hold off installing till their update/fix)
  • SafariStand
  • SafariBlock
  • Shimo
  • SimpleTask
  • Skitch
  • SmartScroll
  • Sprint - for wireless cards - NOT working and freezes computer on shutdown
  • Sonos
  • Split&Concat
  • Sticky Windows
  • Times
  • TiVO Desktop
  • Vuze
  • Wuala
  • Worgroup Manager
  • WindowShadeX
  • WideMail
  • Wakoopa Tracker
  • Xmarks for Safari
  • Xmarks 1.2.1
  • Yoggie Mac Driver 10.6 driver in development, perhaps by 31 October 2009.

Applications with Minor Issues

  • Boxee
  • Bowtie (some skins don't work)
  • Butler
  • CS4 (will be updating after SL, most likely)
  • Glims (Installs but doesn't show up in Safari prefs) (I have no problems at 10.6.2. Prefs show up).
  • Inquisitor (Installs but doesn't show in safari prefs)
  • Letterbox 32-Bit and 64-Bit beta. Seems stable but has not been fully tested.
  • MS Office 2008 (Really SLOW)
  • Plex
  • Reunion
  • Speed Download
  • Squirrel
  • TextMate
  • What Size
  • Yasu

Applications that are now working/fixed, but previous versions have issues

Application Name Working Version Broken Version(s) Problem(s)
Sophos Anti-Virus 7.0.5 7.0.4 or earlier
Panic Candybar 3.2 or Later Earlier than 3.2 As it tinkers with the inner workings of the OS, Candybar is a likely candidate for update breakage. Program would not launch.
Cyberduck 3.3b1 or Later 3.2.x or Earlier Crashed on startup.
Parallels Desktop 4.x, 5.x 1.x, 2.x, 3.x
Dropbox
ElectricSheep Screensaver 2.7b17 or Later 2.7b16 or Earlier
iStat Menus 2.x 1.x Froze computer.
Little Snitch
TinkerTool 3.96 or Later 3.95 or earlier As it tinkers with the inner workings of the OS, TinkerTool is a likely candidate for update breakage. Program would not launch.
SuperDuper! 2.6 or Later 2.5 or Earlier
Undercover 3.1 or Later 3.0.x or Earlier